Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
???
08/17/11 08:20
Read: 887 times


 
#183384 - AT89C51 EEPROM Read Errors
Hi All,

This is a question regarding unusual read errors when we are using the EEPROM on an Atmel AT89C51CC03 (PQFP44) device. Once booted and running the EEPROM reads fine. We have checksums in place for all the EEPROM data and all is fine.

However, we have problems with the first few reads after power up. Sometimes (about 50% of the time) we get incorrect values. The number of bad reads changes within different builds of software.

I have tried delays to allow the power to settle, accessing other peripherals first to settle the IB bus and have monitored the PSU and Reset signals with a good scope and cannot see any problems or differences between good starts and bad.

I can't give exact details of the code as we have tried a huge number of different code builds to try and create/solve the problem but it always seems to be there. As I said once it's working error free (after a good start and after a bad start) it continues to do so.

There don't appear to be any chip erratas regarding this behaviour.

Has anyone else seen any sort of similar behaviour and if so did you solve it?

Thanks for any help,

Dirk Vermaak

List of 8 messages in thread
TopicAuthorDate
AT89C51 EEPROM Read Errors      Dirk Vermaak      08/17/11 08:20      
   'similar'      Erik Malund      08/17/11 08:50      
   OnBoard EEPROM      Michael Karas      08/17/11 12:48      
   Thanks      Dirk Vermaak      08/18/11 01:43      
   Is it possible....      Michael Karas      08/18/11 06:48      
   Another Question      Michael Karas      08/18/11 06:54      
   Are You Disabling      Michael Karas      08/18/11 07:10      
   Validating EEPROM Content      Michael Karas      08/18/11 07:21      

Back to Subject List