Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
???
01/17/12 03:54
Read: 401 times


 
#185527 - Problem solved, query still remains
Responding to: ???'s previous message
Ok Iíve fixed the problem here is what I did


;Instead of
IF A>=0x03
 SETB GAIN_ERROR
 RET
ENDIF
;I have written
CJNE A, #0x03, INC_A_1
 SETB GAIN_ERROR
 RET
INC_A_1
; I just have to hope that there is no error above 4
;and for
IF A=#0x00
 SETB GAIN_ERROR
 RET
ENDIF
; I made a simple JZ opperation
JZ ERR


 


Thanks to all who replied and I'm still very curious to if I may IF statment in the future

List of 17 messages in thread
TopicAuthorDate
Conditional Statements      Donagh Choghlan      01/17/12 02:57      
   Hex constants?      Oliver Sedlacek      01/17/12 03:18      
      0x00, 0x01, 0x02??      Donagh Choghlan      01/17/12 03:28      
   What is the octothorpe?      David Prentice      01/17/12 03:31      
      #      Donagh Choghlan      01/17/12 03:40      
         Immediate or not      Per Westermark      01/17/12 07:31      
      what is an octothorpe?      Andy Peters      01/17/12 10:49      
         Previously, on 8052.com      Andy Neil      01/17/12 15:02      
   Problem solved, query still remains      Donagh Choghlan      01/17/12 03:54      
      Do some trial and error      David Prentice      01/17/12 04:14      
      Check the CJNE instruction...      Robert Revens      01/17/12 06:31      
         Handy that!      Donagh Choghlan      01/17/12 07:18      
      run time vs compile time      Maarten Brock      01/17/12 07:14      
         IF only at assemble      Donagh Choghlan      01/17/12 07:23      
            Not Really!!      Michael Karas      01/17/12 08:47      
               I second that      Erik Malund      01/17/12 08:58      
            Hw variants or debugging are big users of conditionals      Per Westermark      01/17/12 09:40      

Back to Subject List