Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
Jim Granville
01/16/13 12:38
Read: 858 times


 
#189197 - Some things to check...
Responding to: Koen De Ganck's previous message
Koen De Ganck said:
The Philips (NXP) chip always starts, but the other fails more than 50%.
The external reset chip is LM810 (push-pull), with series resistor of 3K3 ( reset > 200ms), 1 extra HC port load


Check the ALE pin, that can show what mode the device started in, and when it exits reset.
Is this only on a cold start ? If you do a small brownout, just enough to trigger the LM810, or a manual reset, is that always OK ?

Can you add a first line of code that flips an unused pin, on reset, so you can check if the issue is really reset.

I have noticed the Reset Hyst of the LP51's is on the low side, but that is only seen on external RST drive with slow edges.

The POL Pin is a simple EXOR with the RST pin, so is unlikely to do anything magical.

Do you use the Xtal signals for anything ?

List of 24 messages in thread
TopicAuthorDate
Reset issue with new Atmel AT89LP51ED2      Koen De Ganck      01/16/13 02:42      
   Do never use a ┬ÁC from which only a preliminary...      Kai Klaas      01/16/13 05:48      
      configuration settings      Koen De Ganck      01/16/13 05:59      
         what about negative reset?      Jan Waclawek      01/16/13 06:56      
            good idea but      Koen De Ganck      01/16/13 07:23      
   Some things to check...      Jim Granville      01/16/13 12:38      
      also try no LM810 at all      Jim Granville      01/16/13 13:02      
         reset is inverted      Koen De Ganck      01/16/13 13:30      
      no strange signals      Koen De Ganck      01/16/13 13:18      
         Extra modes ?      Jim Granville      01/16/13 16:30      
            pull-up on PSEN solves the problem      Koen De Ganck      01/17/13 03:01      
               small capacitor ?      Jim Granville      01/17/13 13:06      
                  small capacitor      Koen De Ganck      01/17/13 14:10      
   side-stepping the problem?      Jan Waclawek      01/17/13 01:34      
      SST could be an option      Koen De Ganck      01/17/13 03:08      
   final status AT89LP51ED2 reset      Koen De Ganck      01/17/13 07:43      
      Clarifies       Jim Granville      01/17/13 12:59      
         loads on PSEN      Koen De Ganck      01/17/13 14:06      
            An isolated PSEN works fine ?      Jim Granville      01/17/13 14:30      
               GAL causes problem      Koen De Ganck      01/17/13 15:41      
                  ATF16V8CZ has Pin-keeper      Jim Granville      01/17/13 16:02      
                     'Z' indeed      Koen De Ganck      01/17/13 16:35      
                        ATF16V8BQL has Icc of ~1.5mA      Jim Granville      01/17/13 16:54      
                           'BQL' version could be an option      Koen De Ganck      01/17/13 17:50      

Back to Subject List