Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
Richard Erlacher
04/10/13 14:38
Read: 942 times
Denver, Co
USA


 
#189651 - O.K. so what have you learned?
Responding to: Narendra Jha's previous message
First of all, you're convinced that the two RF modules do function properly, is that right? Which LED is it that's not glowing? Have you tried examining the signals with an oscilloscope? Have you got access to a logic analyzer? How about a pulse detector?

Have you compared the signal from the PC to the RF module with that from the MCU to the RF module? How about that from the RF module to the PC, and from the RF module to the MCU?

Have you made any effort to ensure that the MCU understands the format and frequency of the demodulated signal from the RF module? Does the signal from the RF module adhere to that format? Is that signal truncated at either end?

RE





List of 12 messages in thread
TopicAuthorDate
PC to 8051 wireless communication problem using Tarang F4.      Narendra Jha      04/06/13 12:11      
   do you suppose it could be a timing issue?      Richard Erlacher      04/06/13 23:11      
      i don't think there is any timing issue.      Narendra Jha      04/07/13 02:12      
         maybe it's the timing generated by that USB-to-serial module      Richard Erlacher      04/07/13 08:43      
            will check this out      Narendra Jha      04/08/13 06:10      
   RTS, CTS etc      Erik Malund      04/08/13 10:17      
      Modem Control Lines      Andy Neil      04/08/13 12:20      
      it says, "Note : CTS and RTS are optional."       Richard Erlacher      04/09/13 16:37      
         transmitter is transmitting      Narendra Jha      04/10/13 14:06      
      it didn't work      Narendra Jha      04/10/13 14:11      
         O.K. so what have you learned?      Richard Erlacher      04/10/13 14:38      
   problem solved      Narendra Jha      05/11/13 02:15      

Back to Subject List