Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
Michael Karas
06/17/13 06:49
Read: 1497 times
Beaverton Or
USA


 
Msg Score: +1
 +1 Informative
#189943 - Tried it out.
Responding to: Erik Malund's previous message
I archived my older paid license Keil C-51 folders and then removed all SiLabs and Keil stuff off of my Win 7 computer. I then downloaded the new package from Erik's link. After installation of the SiLabs package and also the Keil uVision debug driver (which was a separate download from the SiLabs web site) I was able to successfully use the tool set in the "limited" mode.

After applying for the product code via the SiLab's web site -- a process which involved a few minutes of putting in certain information -- I got the code needed within seconds right on the web page.

You use this product code to register for a license code for the Keil software by opening the Keil uVision IDE and opening the license management dialog. That dialog takes you to the Keil web site where you fill out another form. That action results in you receiving an email with the actual product registration code which you enter into the license management dialog in the Keil IDE.

Once the Keil software is registered it worked nicely for me on a project in the "unlimited" mode. I was also able to take a project I had in the SiLabs IDE and create a new Keil uVision 4 project and operate within the Keil IDE. After installing the SiLab's uVision DLL and hooking that into the Keil IDE I was even able to launch a debug session with my target SiLabs C8051F805 MCU on a product board. I did experience some marginal behavior operating uVision 4 in this debug mode and the IDE hung once or twice and needed to be force closed. This is similar experience I had trying to use the SiLabs uVision DLL a number of years ago. These days I mostly just use the SiLabs IDE for development and debugging and find it to be reliable. That despite some of the serious deficiencies of their debugger and key missing features. The main one being not having symbols interpreted in the disassembly window. (I've filed postings on the SiLabs forums and sent emails to SiLabs several times over the years to try to get them to improve the IDE but never get a response back from them. I guess they are too busy fixing other IDE bugs and adding new derivatives to the IDE).

List of 13 messages in thread
TopicAuthorDate
free unlimited Keil        Erik Malund      06/12/13 16:44      
   Interesting but vague       Jim Granville      06/12/13 16:56      
      they are ironing out a few issues      Erik Malund      06/13/13 07:55      
         happens more lately        Maarten Brock      06/14/13 01:51      
            Certainly not unique      Andy Neil      06/15/13 13:29      
   RE: "commercial restriction"      Andy Neil      06/15/13 13:35      
      yes, it is, of course, restricted to SILabs chips      Erik Malund      06/15/13 16:56      
         How go they do that?      Andy Neil      06/18/13 14:22      
            I have some guesses, but no intention of ...      Erik Malund      06/18/13 14:26      
            Possibly this way..?      Raghunathan      07/19/13 23:18      
               but...      Andy Neil      07/20/13 09:43      
   Tried it out.        Michael Karas      06/17/13 06:49      
      DisAsm       Jim Granville      06/17/13 17:36      

Back to Subject List