Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
???
04/18/12 16:27
Modified:
  04/18/12 16:36

Read: 529 times


 
#187214 - LCD
Responding to: Erik Malund's previous message
Hi. I have made code with meaning full headers and change it a bit and simulation works fine. But know i have programed the chip and LCD display won't initialize. Could somebody have quick look at init_lcd and tell me what is missing i think the delay but not sure.

// sometimes half of screen is showing squares when i disconnect and connect battery.


INIT_LCD:
	CLR RS
	MOV MYDATA, #38H
	SETB EN
	CLR EN
	LCALL WAIT_LCD
	CLR RS
	MOV MYDATA, #0EH
	SETB EN
	CLR EN
	LCALL WAIT_LCD
	CLR RS
	MOV MYDATA, #06H
	SETB EN
	CLR EN
	LCALL WAIT_LCD
	RET
 



List of 9 messages in thread
TopicAuthorDate
[project]Calculator 4x4 keypad + 2x16LCD - Result      Lukasz Stanowski      04/07/12 09:57      
   wrong approach      Erik Malund      04/07/12 14:45      
      LCD      Lukasz Stanowski      04/18/12 16:27      
         Initialise it more than one time      Maunik Choksi      04/19/12 01:38      
            Needing To Do Three Times Is A Kludge      Michael Karas      04/19/12 20:48      
               Thanks      Maunik Choksi      04/19/12 23:18      
                  Intent Applied; But Verified??        Michael Karas      04/20/12 05:34      
                     previous experiences      Erik Malund      04/20/12 06:12      
                     ' Will see it again      Maunik Choksi      04/20/12 22:22      

Back to Subject List