Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
Rustu Kaya
11/05/12 14:49
Read: 500 times
Istanbul
Turkey


 
#188783 - re:
Responding to: Andy Neil's previous message
Andy Neil said:
Why the Chat forum? This is an 8051-specific question!

Sorry for the wrong forum. Awkwardness of mine. I wish I could correct it.

Rustu Kaya said:
couldn't get it into idle mode.

Andy Neil said:
How are you sure it's never getting into Idle Mode?


Right after I stopped all interrupts, I set the PCON.0 and then placed some code making an outport's pin toggling. It was still toggling.


Atmel's AT89C4051 Datasheet, Section 9, page 7 said:
The idle mode can be terminated by any enabled interrupt


Andy Neil said:
Could it not be that it does get into Idle Mode, but the exits (almost) immediately due to an interrupt...?


I suppose so,
Would it be the reason I have used an external clock for the controller?






List of 8 messages in thread
TopicAuthorDate
idle mode problem.      Rustu Kaya      11/04/12 11:22      
   Idle Mode?      Joseph Hebert      11/04/12 13:46      
      RE: is there some special "idle mode" wrt the 805x hardware?        Andy Neil      11/05/12 00:34      
         Idle modes      Joseph Hebert      11/05/12 05:21      
   RE: couldn't get it into idle mode      Andy Neil      11/05/12 00:50      
      re:      Rustu Kaya      11/05/12 14:49      
         Check LST and try PD      Jim Granville      11/06/12 14:32      
   how do you know?      Erik Malund      11/05/12 07:20      

Back to Subject List