Email: Password: Remember Me | Create Account (Free)

Back to Subject List

Old thread has been locked -- no new posts accepted in this thread
Mahmood Elnasser
06/05/13 14:29
Read: 2064 times
Sacramento
USA


 
#189863 - ULINK2 and J-link
Responding to: Mahmood Elnasser's previous message
I looked at keil documentation and found the ULINK2 does debugging and trace also while the J-link I had earlier does only debugging.
I connected my ULINK2 to the board, keil recognizes the ULINK2 ok but always gives me SWD communication failure. Not sure what is wrong I tried the J-link I had and to my surprise keil detected that my J-Link is Chinese clone to the original and exited.
Not sure if my ULINK2 is a clone also because I bought it from china for 25$. However keil does not complain about it. Could this SWD communication failure be due to the fact that ULINK2 is a clone?
In my debugging I noticed the reset pin out of JTAG cable always hi as if there is driver problem with PC. I upgraded the driver but still problem not solved.
Mahmood


List of 10 messages in thread
TopicAuthorDate
LPC810 demo board      Mahmood Elnasser      05/11/13 15:18      
   quick start video tutorial      Mahmood Elnasser      05/24/13 14:26      
   ULINK2 and J-link      Mahmood Elnasser      06/05/13 14:29      
      What's wrong with SWD?      Oliver Sedlacek      06/06/13 04:45      
         what is SWD?      Erik Malund      06/06/13 07:04      
            Serial Wire Debug SWD      Mahmood Elnasser      06/06/13 08:54      
               SWD capabilities      Oliver Sedlacek      06/06/13 10:13      
      Problem solved      Mahmood Elnasser      06/06/13 14:14      
         So how did you fix it?      Andy Neil      06/10/13 15:50      
            modified the board        Mahmood Elnasser      06/11/13 02:33      

Back to Subject List